Too early to upgrade WordPress to 2.6 easily

I’ve developed what appears once again to be a good habit – NOT to upgrade a WordPress instance soon after new [sub-]version release. Wait at least a month.

Indeed, why hurry? I back up both database and file systems regularly and automatically, most inherently insecure features of the system (like user registration) are turned off, Apache’s mod_security is in place…

However, the rule of waiting a month (more is better) for a release to mature resulted in my installation being stuck with some old version of WP (2.2) – they just were updating way too quickly. And I started to feel slow in implementing new features in my blogs. So I took a plunge with WordPress 2.6.
Continue reading